Building placement


  • TF#12 - PEOPLE'S HERALD

    When you place a building in the town, there seems to be an extra invisible area of width to a building that is facing east, as opposed to facing south. The workshop, despite looking like a square, will be shiny blue if i have it facing south hugging the roads... but if i have it facing east hugging the road, it's a bright red, despite not being on top of a road. It says it is, but it isn't. This seems to only be present with the Tavern, Workshop and Magic Shop out of all the Tier 1 city buildings.

    workshop 1.jpg

    workshop 2.jpg


  • TF#12 - PEOPLE'S HERALD

    With all of the resource storages, it is the opposite, but it instead thinks there isn't a road present at all!!
    umm.jpg


  • Content Creator

    Wagon Parking???


  • TF#12 - PEOPLE'S HERALD

    Nope. no wagons nearby at all. I have asked everyone to park them on the roads, so I don't have to delete them to place blueprints. Almost all of the citizens have graciously done that, which has been a blessing 🙂


  • Content Creator

    @Xzait no, it was a joke, as in those buildings automatically allow a ribbon of land for parking as part of their specs


  • TF#12 - PEOPLE'S HERALD

    @GamerSeuss ah, I see. that's hella lame. What a waste of space for the city... I hope your joke isn't right on the money, and it is intentional... 😕


  • TF#12 - PEOPLE'S HERALD

    To further plot the issues with this bug. I tried placing it facing south, to test @GamerSeuss's theory, right up against the edge of town. As I expected, the roads were interfering, so I deleted them. It then allowed me to place the Workshop, despite being in the same spot it was saying it was over a road previously. I was then able to place the roads back without issues. I was also able to place even more roads... and more...

    placement issues.jpg


  • TF#12 - PEOPLE'S HERALD

    Also, when the blueprint isn't completed, the area of which blueprints affect one another are very different.


  • Content Creator

    Mayhaps those buildings require a road on that side of the building to place them, to be built after they are placed


  • TF#12 - PEOPLE'S HERALD

    I have another issue with placing a storage building on a space where it would fit, but it tells me, it isn't on a road, even it is:
    Blueprint01.PNG
    (sidenote: i know there is a Wagon, but i tried same without this wagon before and had same result. Screenshots just made to post here)

    There is a road, because i can add a road at the place where i want the storage:
    Blueprint02.PNG

    Also the size of building should fit, because the other wood storage is on same postion on the other side. I just think the road is preventing the placement, since i can't add another roadpart towards the Townhall to the right and the precondition needs the next streetpart to get fullfilled?
    Blueprint03.PNG


Log in to reply
 

Copyright © 2021 Dynamight Studios Srl | Fractured