Adv Smelter Appears to eat resources



    Advanced smelter appears to eat resources. No timer given, resources not listed, but timer does say cancel. Will update if it completes


    UPDATE: Smelters completed. NO INGOTS

  • Moderator

    Which ore did you put in?


    It was 5 coal and 10 iron. i havent tried them yet today cause im scared to 🙂

  • Hey there!
    I confirm this bug has been reported and is being looked into.
    Thank you very much!


    @Arcahem said in Adv Smelter Appears to eat resources:

    Hey there!
    I confirm this bug has been reported and is being looked into.
    Thank you very much!

    Awesome TY. I confirmed as of yesterday its still doing it

  • I've made Iron, Tin, Silver and Copper in them. I used them for 3 days without issues. Using one advanced smelter and 2 regular smelters at the same time, the advance smelters eat everything I put in right away. But, after the other two smelters finished and were emptied, the advanced smelter worked again. I'm sure curious if it's using multiple smelters at the same time that is the issue, or if it's just a hit and miss bug.

    I'll do more testing tomorrow and Monday.


    i just stopped using them until they're fixed. then ill foolishly replace all with adv

  • A little update: With the patch that released 05/04, discussion started about the advanced smelter fix previously mentioned by Jacopo on Discord. About a week ago on 04/27 @Prometheus had mentioned possibly having a patch that addressed this out by Friday 04/29.


    Jacopo provided an update and the discussion ultimately ended with him committing to "get on it personally ASAP".



    So I wanted to update the thread and contribute my own findings in the event it helps track things down. Our smelter plot in Braavos is made up of 8x basic smelters and has a row of 4x advanced smelters in the back. I had only recently placed the advanced smelters a few days ago as people mentioned having some luck with them. I had heard that the first batch always worked.. So I decided to load one up with 10x Iron ore, 3x coal, and 1x, charcoal. I loaded the ores first, finished with the fuel, and then pressed smelt. The first batch in all four advanced smelters worked fine. The second batch was also successful, it was10x tin ore and 1x coal in each, the batch was started and completed after the server restart the morning of 05/04. The third batch was going to be tin again (10x tin ore, 1x coal in each) but it bugged, similar to what @DarthJafo explained. On pressing the smelt button, the temp indicator line falls to the bottom but the temp of the fuel stays present. The fuel and ore all disappear but the smelt buttons turns in to a cancel button. One difference about my situation was the ore still read 5/5 and 5/5 but the ore is gone. The issue occurs right when you hit the smelt button, instead of the gray overlay covering the ore sockets and the timer starting.. your ore just vanishes. The timer never starts but the advanced smelter begins smoking and the cancel button remains for the full duration. At the end of the batch nothing is in the smelter.


    I hit cancel on the first one and it did not return anything. I posted my results to the #debate_tavern channel on discord where we can post screenshots. Someone asked if I had tried moving one of the smelters to another place on the plot and then trying again. I decided to give it a try and it worked, the fourth batch (10x tin ore, 1x coal in each) worked. The third bugged, I moved the smelter to a free spot and then back to the original place and it successfully started and later completed a batch. After seeing this I decided to move another advanced smelter to see if it would work. This smelter had NOT consumed ore prior to me moving it but after moving it the third batch bugged and it consumed all ore. So moving an advanced smelter after it bugged a batch restored it for at least the next batch attempt.. However, moving a non-bugged advanced smelter before attempting a batch did not prevent it from bugging out the same as the others.

    Hopefully this information is helpful.. We lost some ore testing this so we will not be using the advanced smelters again until an official fix is released.

  • I managed to build 2 advanced smelters finally and started making some copper with it. For me also, 2 first batches of copper were fine, but the third ate my ore and charcoal. My ore slots were both 5/5 copper and fuel 4x charcoal. Aside from the 2 advanced ones, I also have 5 normal smelters that were loaded up at the same time.

    Hopefully this gets sorted out soon 🙂

    EDIT: I tried also not moving the other advanced smelter and moving the other to a free spot and back and seeing if there was difference, however both smelters went like the one in the screenshot. I'm quessing I'm not getting my ingots this time either. The normal smelters are running this run again.

    I always load up copper/ores first to every smelter then load fuel the next round and last round i start everything up.

    EDIT 2: I tried adding copper ore while it was running and the earlier ores had disappeared. Interestingly, the first ore i put inside brought back the counter for the first slot, with the timer showing the correct amount of time left in the smelting process. Then I added 5 more (4 went to the first slot to fill it i quess) and the 5th ore brought back the timer and ore in the second slot. The same with the other smelter, added 6 copper ore in it and both slots were back in business.

    I'll need around 3:50 to see if I get some ingots.

  • I did get all the ingots after the timer was complete. So I added 6 extra ingots in each adv. smelter after the ores were eaten, but the process started.

Log in to reply

Copyright © 2022 Dynamight Studios Srl | Fractured